Навигация

QUIK

Вы можете использовать подключение через QUIK с любым брокером, предоставляющим для торговли терминал QUIK. Наиболее популярные брокеры:

Для настройки подключения:

1. Запустите QUIK и откройте перечисленные ниже окна. Для добавления окна в главном меню QUIK выберите Создать окно → Все типы окон, и в открывшемся окне из списка выберите нужный. Колонки в таблицах открытых окон могут быть любыми.

  • Текущие торги
  • Таблица обезличенных сделок
  • Заявки
  • Стоп-заявки
  • Сделки
  • Позиции по инструментам (лимиты по бумагам в старых версиях Quik)
  • Позиции по деньгам (лимиты по денежным средствам в старых версиях Quik)
  • Ограничения по клиентским счетам
  • Позиции по клиентским счетам
     

2. В главном меню QUIK выберите Система → Настройки → Основные настройки. В левой части открывшегося окна выберите Программа → Получение данных и убедитесь что не включена опция Запрашивать данные раз в 10 сек

3. В главном меню QUIK выберите Система → Настройки → Основные настройки. В левой части открывшегося окна выберите Программа → Получение данных → Котировки. Отметьте галочками классы инструментов, которые будете использовать в своей торговле. Также убедитесь, что у выбранных классов инструментов не включена опция Фильтр параметров. 

4. В главном меню QUIK выберите Система → Настройки → Основные настройки. В левой части открывшегося окна выберите Программа → Получение данных → Обезличенные сделки. Отметьте галочками классы инструментов, которые будете использовать в своей торговле. Если список классов пуст, или отсутствуют необходимые классы, обратитесь к своему брокеру для их подключения.

5. В окно Текущие торги добавьте все инструменты, которые будете использовать в своей торговле. 

6. В окно Таблица обезличенных сделок добавьте все инструменты которые будете использовать в своей торговле. Убедитесь, что идёт трансляция сделок по выбранным инструментам, иначе графики не будут обновляться. У некоторых брокеров трансляция сделок отключена, и они подключают её по запросу.

7. В главном меню QUIK выберите Сервисы → Lua скрипты. В открывшемся окне нажмите Добавить и выберите файл С:\ProgramFiles(x86)\TigerTrade\Connectors\Quik\TigerTrade.Quik.lua

Далее выделите этот файл и нажмите Запустить. Дождитесь завершения запуска скрипта (появления зелёной стрелки).

8. Запустите TigerTrade и в главном меню выберите Файл → Подключения → Настроить.

9. В открывшемся окне нажмите кнопку «+» Создать новое подключение и в появившемся списке выберите QUIK.

10. В следующем окне в выпадающем списке выберите путь к терминалу QUIK. Если вы используете только один этот терминал на своём компьютере, то можете оставить пункт Определять путь автоматически. При торговле через некоторых брокеров, в момент выставления заявки может появиться сообщение, что не задан код клиента. В этом случае установите галочку Добавлять код клиента к счёту и перезапустите терминал. Нажмите OK.

На этом настройка подключения завершена. Если настройка выполнена правильно, появится сообщение о том, что соединение с терминалом QUIK установлено. В дальнейшем соединение будет устанавливаться автоматически после запуска Lua-скрипта в QUIK.

Вы также можете предварительно ознакомиться с особенностями используемой версии QUIK.



Была ли эта статья полезной? Да Нет

Отправить отзыв
К сожалению, мы не смогли помочь вам в разрешении проблемы. Ваш отзыв позволит нам улучшить эту статью.